LISTSERV mailing list manager LISTSERV 16.0

Help for XML-L Archives


XML-L Archives

XML-L Archives


XML-L@LISTSERV.HEANET.IE


View:

Message:

[

First

|

Previous

|

Next

|

Last

]

By Topic:

[

First

|

Previous

|

Next

|

Last

]

By Author:

[

First

|

Previous

|

Next

|

Last

]

Font:

Proportional Font

LISTSERV Archives

LISTSERV Archives

XML-L Home

XML-L Home

XML-L  December 2000

XML-L December 2000

Subject:

Re: XSL question

From:

Wim Van hoorde <[log in to unmask]>

Reply-To:

General discussion of Extensible Markup Language <[log in to unmask]>

Date:

Wed, 13 Dec 2000 13:57:59 +0100

Content-Type:

text/plain

Parts/Attachments:

Parts/Attachments

text/plain (315 lines)

You are using a wrong namespace.

xmlns:xsl="http://www.w3.org/TR/WD-XSL" works fine by me

greetz

wim

-----Original Message-----
From: Verma, Sanjay [mailto:[log in to unmask]]
Sent: Wednesday, December 13, 2000 1:43 PM
To: [log in to unmask]
Subject: Re: XSL question


Hi

My xsl file is



<?xml version="1.0" ?>
<xsl:stylesheet xmlns:xsl="http://www.w3.org/1999/XSL/Transform"
version="1.0">
<xsl:output method="html"/>
<xsl:template match="/">
<HTML>
<HEAD>
<TITLE><xsl:value-of select="//summary/heading"/></TITLE>
</HEAD>
<BODY>
    <h1><xsl:value-of select="//summary/heading"/></h1>
    <h2><xsl:value-of select="//summary/subhead"/></h2>
    <p><xsl:value-of select="//summary/description"/></p>
</BODY>
</HTML>
</xsl:template>
</xsl:stylesheet>




and XML file is


<?xml version="1.0" ?>
<?xml-stylesheet type="text/xsl" href="Txsl.xsl"?>
<sales>
<summary>
    <heading>Northwind.com</heading>
    <subhead>Regional Sales Report</subhead>
    <description>Sales report for the West Coast, Central, and East
      Coast regions.</description>
</summary>
<data>
  <region>
  <name>West Coast</name>
    <quarter number="1" widgets_sold="24000" />
    <quarter number="2" widgets_sold="38600" />
    <quarter number="3" widgets_sold="44030" />
    <quarter number="4" widgets_sold="21000" />
  </region>
  <region>
    <name>Central</name>
    <quarter number="1" widgets_sold="11000" />
    <quarter number="2" widgets_sold="16080" />
    <quarter number="3" widgets_sold="25000" />
    <quarter number="4" widgets_sold="29000" />
  </region>
  <region>
  <name>East Coast</name>
    <quarter number="1" widgets_sold="27000" />
    <quarter number="2" widgets_sold="31400" />
    <quarter number="3" widgets_sold="40100" />
    <quarter number="4" widgets_sold="30000" />
  </region>
</data>
</sales>




I am using IE5.5 browser, but when i browse xml file see a blank screen.

Please help

Regards
Sanjay Kumar Verma
______________________________________________________________
Associate (1266)
HCL Perot Systems Pvt. Ltd.
Lecture Hall-II, B-31, Basement, Sector 57
Noida India
> * 91-11-8-4581237-41 EXT 3002
______________________________________________________________


> -----Original Message-----
> From: Amit R Bhamare [SMTP:[log in to unmask]]
> Sent: Wednesday, December 13, 2000 3:43 PM
> To:   [log in to unmask]
> Subject:      Re: XSL question
>
> Hi,
> I tried the following code & it worked with IE5.5.........
>
> <?xml version="1.0"?>
> <xsl:stylesheet xmlns:xsl="http://www.w3.org/TR/WD-xsl">
> <xsl:template match="/">
> <html>
>         <head>
>                 <title>XSL</title>
>         </head>
>         <body>
>                 Head...shoulders...
>                 <xsl:for-each select="document/quality">
>                         <xsl:value-of select="."/>
>                 </xsl:for-each>
>                 ....toes
>         </body>
> </html>
>
> </xsl:template>
> </xsl:stylesheet>
>
> Amit
>
> > -----Original Message-----
> > From: Paul Mahon [SMTP:[log in to unmask]]
> > Sent: Tuesday, December 12, 2000 11:05 PM
> > To:   [log in to unmask]
> > Subject:      Re: XSL question
> >
> > Brian,
> >
> > Your namespace declaration is definitely the old one, as Michael
> suggests
> > try using the up to date one:
> > <xsl:stylesheet version="1.0" xmlns:xsl="
> > http://www.w3.org/1999/XSL/Transform">
> >
> > I tested your code using saxon and with the following tweaking it seems
> to
> > successfully output the required HTML:
> > <xsl:template match="document">
> >
> >
> >  <html>
> >          <head>
> >                  <title></title>
> >          </head>
> >          <body leftmargin="0" topmargin="0" marginwidth="0"
> >  marginheight="0">
> >                  Head...shoulders...
> >                  <xsl:for-each select="quality">
> >                          <xsl:value-of select="."/>
> >                </xsl:for-each>
> >                  ...and toes...
> >
> >
> >          </body>
> > </html>
> >
> > That said when I tried it with IE it displayed the HTML but ignored the
> > contents of the XML, dunno why?!?!?
> >
> > Likewise, am not an eX(SL)pert :-)
> >
> > Paul
> >
> > Paul Mahon
> > Internet Development
> > 2038636
> > 087 2602491
> >
> >
> >
> >                     Brian Lasiewski
> >                     <brian.lasiewski@B3INTERA        To:
> > [log in to unmask]
> >                     CTIVE.COM>                       cc:
> >                     Sent by: General                 Subject:     Re:
> XSL
> > question
> >                     discussion of Extensible
> >                     Markup Language
> >                     <[log in to unmask]
> >                     >
> >
> >
> >                     12/12/00 05:01 PM
> >                     Please respond to General
> >                     discussion of Extensible
> >                     Markup Language
> >
> >
> >
> >
> >
> > Thanks much, I'll give it a whirl. Sorry, didn't know there was a
> separate
> > list for this sort of thing. Thanks for the scoop, I'll check it out.
> >
> > B
> >
> > -----Original Message-----
> > From: General discussion of Extensible Markup Language
> > [mailto:[log in to unmask]]On Behalf Of Michael Rossi
> > Sent: Tuesday, December 12, 2000 11:50 AM
> > To: [log in to unmask]
> > Subject: Re: XSL question
> >
> >
> > Brian,
> >         First thing I'd check is your namespace declaration. I'm not
> sure
> > what your using is current, and it depends on what your parser/XSL
> > processor
> > is expecting. Next, your "match="/" already selects the root of your
> > document. But you should probably use something like select="/quality"
> or
> > select="//quality" in your for-each loop, coupled with select="." in
> your
> > value-of.
> >
> >         But I'm by NOOOO means an XSL expert. There's a separate list
> > dedicated to XSL(T) at (I believe) [log in to unmask] If you're
> > still having trouble, I'd try there.
> >
> > Michael A. Rossi
> > Computer Sciences Corporation
> > mailto:[log in to unmask]
> > 856-983-4400 x4911
> >
> >
> > > -----Original Message-----
> > > Brian Lasiewski <[log in to unmask]> on
> > > 12/11/2000 04:58:25 PM
> > >
> > > Hey all,
> > >
> > > I'm really green with the whole XML scene. I've been doing the whole
> > > tutorial and book thing for a bit and have been trying rather
> > unsuccessfully
> > > to get an XSL file to display with data from an associated XML file.
> > >
> > > Today I cracked open another book, did a bunch of reading and started
> > very
> > > simply. Here is the XML file I am working with (it's a file called,
> > > originally enough, "test.xml"):
> > >
> > > <?xml version="1.0" standalone="yes"?>
> > > <?xml-stylesheet type="text/xsl" href="chewy.xsl"?>
> > >
> > > <document>
> > >         <quality>
> > >                 knees
> > >         </quality>
> > > </document>
> > >
> > >
> > > The XSL file (chewy.xsl) that I'm trying to get the data from the
> above
> > > displayed in looks like this:
> > >
> > > <?xml version="1.0"?>
> > > <xsl:stylesheet xmlns:xsl="http://www.w3.org/tr/wd-xsl">
> > >
> > > <xsl:template match="/">
> > >
> > >
> > > <html>
> > >         <head>
> > >                 <title></title>
> > >         </head>
> > >         <body leftmargin="0" topmargin="0" marginwidth="0"
> > > marginheight="0">
> > >                 Head...shoulders...
> > >                 <xsl:for-each select="quality">
> > >                         <xsl:value-of select="quality"/>
> > >                 </xsl:for-each>
> > >                 ...and toes...
> > >
> > >
> > >         </body>
> > > </html>
> > >
> > >
> > > </xsl:template>
> > > </xsl:stylesheet>
> > >
> > >
> > > When I view the XSL file in Netscape (v6) I see the HTML without the
> XML
> > > data. When I view the XSL file in MIE 5.5 I get the source code.
> > >
> > > I know I'm missing something really simple here. Can someone point out
> > where
> > > I'm screwing this up? Thanks much,
> >
> >
> >
> >
> >
> >
> > ****************************************************************
> > The information transmitted in this email is intended for the
> > addressee only and may contain confidential and/or privileged
> > material. Any review, retransmission,dissemination,reliance
> > upon or other use of, this information by persons or entities
> > other than the addressee is prohibited.If you received this
> > in error, please contact the sender and delete the material.
> >
> > This message has been swept by Anti-Virus software
> > ****************************************************************

Top of Message | Previous Page | Permalink

Advanced Options


Options

Log In

Log In

Get Password

Get Password


Search Archives

Search Archives


Subscribe or Unsubscribe

Subscribe or Unsubscribe


Archives

February 2017
August 2016
June 2016
March 2016
January 2016
July 2014
April 2014
January 2014
July 2013
February 2013
September 2012
August 2012
October 2011
August 2011
June 2011
January 2011
November 2010
October 2010
July 2010
June 2010
March 2010
February 2010
January 2010
November 2009
September 2009
August 2009
July 2009
May 2009
March 2009
December 2008
October 2008
August 2008
May 2008
March 2008
February 2008
January 2008
December 2007
October 2007
August 2007
June 2007
March 2007
January 2007
December 2006
September 2006
July 2006
June 2006
April 2006
February 2006
January 2006
November 2005
September 2005
August 2005
July 2005
June 2005
May 2005
March 2005
January 2005
October 2004
August 2004
July 2004
June 2004
May 2004
March 2004
February 2004
January 2004
December 2003
November 2003
October 2003
September 2003
August 2003
July 2003
June 2003
May 2003
April 2003
March 2003
February 2003
January 2003
December 2002
November 2002
October 2002
September 2002
August 2002
July 2002
June 2002
May 2002
April 2002
March 2002
February 2002
January 2002
December 2001
November 2001
October 2001
September 2001
August 2001
July 2001
June 2001
May 2001
April 2001
March 2001
February 2001
January 2001
December 2000
November 2000
October 2000
September 2000
August 2000
July 2000
June 2000
May 2000
April 2000
March 2000
February 2000
January 2000
December 1999
November 1999
October 1999
September 1999
August 1999
July 1999
June 1999
May 1999
April 1999
March 1999
February 1999
January 1999
December 1998
November 1998
October 1998
September 1998
August 1998
July 1998
June 1998
May 1998
April 1998
March 1998
February 1998
December 1997
November 1997
October 1997

ATOM RSS1 RSS2



LISTSERV.HEANET.IE

Secured by F-Secure Anti-Virus CataList Email List Search Powered by the LISTSERV Email List Manager